Quantcast

SPSSINC HETCOR in SPSS 24

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SPSSINC HETCOR in SPSS 24

Kidiot18
Hi!

I am using SPSS 24 and would like to run the heterogenous correlation module/SPSSINC HETCOR bundle, but it is not really working.
Before I installed the SPSSINC HETCOR bundle, I downloaded R version 3.2.0, which is required for the SPSS essentials for R plugin to work with SPSS 24. I assume the installation was successful, because when I run the code to check, it prints ‘ok’:

begin program.
import spss
print 'ok'
end program.
ok
begin program r.
print('ok')
end program.
[1] "ok"

However, when I try to run the heterogenous correlation it says <type 'exceptions.Exeptions'> and warns that the R package ‘polycor’ is required but could not be loaded.
‘Polycor’ only runs in 3.3.2 version of R. However, I cannot update R because then the SPSS essentials plugin is not working anymore as it needs to be installed in a directory of R version 3.2 (for SPSS 24). As far as I know there is no other plugin I could use.
Unfortunately, I don’t know how to solve this problem – I would greatly appreciate any help!

Thank you very much!
Kim
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SPSSINC HETCOR in SPSS 24

Jon Peck
polycor should have been installed with the HETCOR extension.  If it was not, due to lack of an Internet connection at install time or some other reason, you can install it by starting Rgui, which is part of the standard R installation, and using the Packages menu.

When you say that the R Essentials plugin is not working anymore, what happens when you try to use it, say like this?

begin program r.
print(sessionInfo())
end program.




On Wed, Feb 8, 2017 at 6:13 AM, Kidiot18 <[hidden email]> wrote:
Hi!

I am using SPSS 24 and would like to run the heterogenous correlation
module/SPSSINC HETCOR bundle, but it is not really working.
Before I installed the SPSSINC HETCOR bundle, I downloaded R version 3.2.0,
which is required for the SPSS essentials for R plugin to work with SPSS 24.
I assume the installation was successful, because when I run the code to
check, it prints ‘ok’:

begin program.
import spss
print 'ok'
end program.
ok
begin program r.
print('ok')
end program.
[1] "ok"

However, when I try to run the heterogenous correlation it says <type
'exceptions.Exeptions'> and warns that the R package ‘polycor’ is required
but could not be loaded.
‘Polycor’ only runs in 3.3.2 version of R. However, I cannot update R
because then the SPSS essentials plugin is not working anymore as it needs
to be installed in a directory of R version 3.2 (for SPSS 24). As far as I
know there is no other plugin I could use.
Unfortunately, I don’t know how to solve this problem – I would greatly
appreciate any help!

Thank you very much!
Kim



--
View this message in context: http://spssx-discussion.1045642.n5.nabble.com/SPSSINC-HETCOR-in-SPSS-24-tp5733783.html
Sent from the SPSSX Discussion mailing list archive at Nabble.com.

=====================
To manage your subscription to SPSSX-L, send a message to
[hidden email] (not to SPSSX-L), with no body text except the
command. To leave the list, send the command
SIGNOFF SPSSX-L
For a list of commands to manage subscriptions, send the command
INFO REFCARD



--
Jon K Peck
[hidden email]

===================== To manage your subscription to SPSSX-L, send a message to [hidden email] (not to SPSSX-L), with no body text except the command. To leave the list, send the command SIGNOFF SPSSX-L For a list of commands to manage subscriptions, send the command INFO REFCARD
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SPSSINC HETCOR in SPSS 24

Kidiot18
Hi Jon,

Many thanks for your quick response!

(1) No matter how often I install and uninstall the programmes/bundles SPSS still tells me that the required polycor package could not be loaded when I use the SPSSINC HETCOR command.

(2) I cannot install polycor from the package menu because it is only available in R versions ≥ 3.3.0 (https://cran.r-project.org/web/packages/polycor/index.html)

(3) If I try to use R versions 3.3.0 or 3.3.2 I can no longer install the R plugin, because the R essentials plugin for SPSS 24 requires to be installed in a directory of R version 3.2. That was what I meant by saying the plugin is not working, it cannot be installed.

Neither can I find another plugin that allows using SPSS 24 and R 3.3 together, nor do I know how to install polycor in R version 3.2. I just can't figure out how to solve this. Maybe I am missing something... Do you have another idea?

Thank you!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SPSSINC HETCOR in SPSS 24

Jon Peck
You have to use R3.2.x.  However, the polycor package is available for that release under Older Versions.  I will send this to you directly.  It is very unusal for an R package to have such a specific version dependency.

On Wed, Feb 8, 2017 at 8:42 AM, Kidiot18 <[hidden email]> wrote:
Hi Jon,

Many thanks for your quick response!

(1) No matter how often I install and uninstall the programmes/bundles SPSS
still tells me that the required polycor package could not be loaded when I
use the SPSSINC HETCOR command.

(2) I cannot install polycor from the package menu because it is only
available in R versions ≥ 3.3.0
(https://cran.r-project.org/web/packages/polycor/index.html)

(3) If I try to use R versions 3.3.0 or 3.3.2 I can no longer install the R
plugin, because the R essentials plugin for SPSS 24 requires to be installed
in a directory of R version 3.2. That was what I meant by saying the plugin
is not working, it cannot be installed.

Neither can I find another plugin that allows using SPSS 24 and R 3.3
together, nor do I know how to install polycor in R version 3.2. I just
can't figure out how to solve this. Maybe I am missing something... Do you
have another idea?

Thank you!



--
View this message in context: http://spssx-discussion.1045642.n5.nabble.com/SPSSINC-HETCOR-in-SPSS-24-tp5733783p5733789.html
Sent from the SPSSX Discussion mailing list archive at Nabble.com.

=====================
To manage your subscription to SPSSX-L, send a message to
[hidden email] (not to SPSSX-L), with no body text except the
command. To leave the list, send the command
SIGNOFF SPSSX-L
For a list of commands to manage subscriptions, send the command
INFO REFCARD



--
Jon K Peck
[hidden email]

===================== To manage your subscription to SPSSX-L, send a message to [hidden email] (not to SPSSX-L), with no body text except the command. To leave the list, send the command SIGNOFF SPSSX-L For a list of commands to manage subscriptions, send the command INFO REFCARD
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SPSSINC HETCOR in SPSS 24

Kidiot18
Thank you so much! Problem solved!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SPSSINC HETCOR in SPSS 24

MollyM
In reply to this post by Jon Peck
Hi Jon,

I am having the exact same problem. Would you mind sending me the older version of the polycor package for SPSS v24?

Many thanks,

Molly
Loading...