Fw: SPSS 17 instability/weirdness

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Fw: SPSS 17 instability/weirdness

SPSS Support-2

Hello Graham,
  It seems that you've encountered a bug in Statistics 17.0 that has been fixed in the 17.0.1 patch. An extra period was inserted at the end of the last line of selected commands if there were spaces after the command terminator (period) in that command. The work-around was to make sure that  the there were no spaces trailing the end of the last command, but installing the patch should resolve this.  Patches are available up to 17.0.3 at http:\\support.spss.com. Click the Statistics link under Main Menu and then the Patches link that appears. I've pasted a related resolution below. As noted there, the extra period triggered different error messages when added to different commands.

David Matheson
Statistical Support
SPSS, an IBM company

********************
Resolution number: 80177  Created on: Oct 16 2008  Last Reviewed on: Dec 7 2009

Problem Subject:  Error when running a syntax command with a blank right after the command terminator

Problem Description:  I am using SPSS Statistics 17.0 and have selected a command such as GET FILE in an existing syntax file, and clicked Run-Selection. However the file is not opened and I get the error message below:

GET FILE="xxx.sav". .
Error # 5213 in column 28. Text: .
GET is expecting one of the keywords RENAME, KEEP, DROP, or MAP at this point, and the symbol is none of those. Either the keyword is misspelled, or there is a punctuation error.
This command not executed.

I have noticed that right after the command terminator of the GET FILE command a blank was typed into the existing sytax.
When I run the complete syntax the file is opened but I get this warning below although the file is not open in another SPSS instance or application, what is the reason?

Warning # 67. Command name: GET FILE
The document is already in use by another user or process. If you make changes to the document they may overwrite changes made by others or your changes may be overwritten by others.

For other commands, the symptoms are different. For example, if after SAVE OUTFILE there is a space following the final period, I get:

Error # 5303 in column 77. Text: .
A symbol not allowed on the SAVE, XSAVE, or SAVE DIMENSIONS command has been
encountered. Check spelling and punctuation.
This command not executed.

Resolution Subject: This problem has been reported to SPSS Development and is fixed with the 17.0.1 Patch.

Resolution Description
This problem has been reported to SPSS Development and is fixed with the 17.0.1 Patch.

It seems that only the last line selected is affected by trailing spaces. Prior to 17.0.1 there is no workaround available other than to ensure that the last line of any selection ends in a period, without any subsequent characters.

We apologize for any inconvenience.



----------
Date: 06/17/2010 10:35 AM
Subject: SPSS 17 instability/weirdness
Sent by: "SPSSX(r) Discussion" <[hidden email]>





I got some really strange behavior with SPSS 17 for windows XP trying to
run a simple do if command. All I was trying to do is this:

do if binaryscenerioID="1".
recode Isrscenerios (5=1) (4=2) (3=3) (2=4) (1=5) into Issagree.
end if.

When I tried to run this though, when SPSS got to the end if command it
put an EXTRA period at the end so that when the syntax displayed in the
output window it looked like this:

do if binaryscenerioID="1".
recode Isrscenerios (5=1) (4=2) (3=3) (2=4) (1=5) into Issagree.
end if. .

And then....everything got weird... SPSS gave me this error message:

"
>Warning # 142.  Command name: end
>LOOP has no effect on this command.

>Error # 1.  Command name: end
>The first word in the line is not recognized as an SPSS Statistics
command.
>This command not executed.

>Warning # 142.  Command name: _SLINE
>LOOP has no effect on this command."


And then EVERY command I put in, freqs, recodes, anything, all just gave
me this error message

">Warning # 142.  Command name: _SLINE
>LOOP has no effect on this command."

Of course I wasn't using loops. I tried to do another end if, or end
loop command but they all just gave me the same error:

">Warning # 142.  Command name: _SLINE
>LOOP has no effect on this command."

I reopened the dataset and everything was back to normal, and ran the
same syntax again,  and it did the same thing again. Finally, I tried
running "end if" WITHOUT a period, and sure enough, SPSS put one in on
it's own and stopped the loop. Then I tried closing the dataset and
opening it up again for a third time, but this time everything works
fine, and running the same exact syntax produces no errors.

 I can't duplicate this bug, so I'm not going to worry about it, but
has anyone else had this problem? I've had some weird experiences with
SPSS doing some really bizzare unstable things in the past (with version
15 mostly),. but I thought we were done with that.

-Graham

=====================
To manage your subscription to SPSSX-L, send a message to
[hidden email] (not to SPSSX-L), with no body text except the
command. To leave the list, send the command
SIGNOFF SPSSX-L
For a list of commands to manage subscriptions, send the command
INFO REFCARD